hadoop-mapreduce-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Akira Ajisaka (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (MAPREDUCE-6821) Fix javac warning related to the deprecated APIs after upgrading Jackson
Date Tue, 13 Dec 2016 18:02:58 GMT

     [ https://issues.apache.org/jira/browse/MAPREDUCE-6821?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Akira Ajisaka updated MAPREDUCE-6821:
-------------------------------------
    Issue Type: Bug  (was: Improvement)

> Fix javac warning related to the deprecated APIs after upgrading Jackson
> ------------------------------------------------------------------------
>
>                 Key: MAPREDUCE-6821
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-6821
>             Project: Hadoop Map/Reduce
>          Issue Type: Bug
>    Affects Versions: 3.0.0-alpha2
>            Reporter: Yiqun Lin
>            Assignee: Yiqun Lin
>            Priority: Minor
>             Fix For: 3.0.0-alpha2
>
>         Attachments: MAPREDUCE-6821.001.patch
>
>
> We should update the deprecated APIs after Jackson upgraded. This issue is similar to
HDFS-11233. In MAPREDUCE, there is just one place using deprecated API. We can updated the
code here.
> {code}
> class JobSubmitter {
>   protected static final Log LOG = LogFactory.getLog(JobSubmitter.class);
>   private static final ObjectReader READER =
>       new ObjectMapper().reader(Map.class);
> {code}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: mapreduce-issues-unsubscribe@hadoop.apache.org
For additional commands, e-mail: mapreduce-issues-help@hadoop.apache.org


Mime
View raw message