hadoop-mapreduce-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dustin Cote (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MAPREDUCE-6642) Move the constructor to a method in HadoopTestCase
Date Thu, 25 Feb 2016 21:09:18 GMT

    [ https://issues.apache.org/jira/browse/MAPREDUCE-6642?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15167882#comment-15167882
] 

Dustin Cote commented on MAPREDUCE-6642:
----------------------------------------

[~ajisakaa] I'll pick this one up.  Thanks for opening :)

> Move the constructor to a method in HadoopTestCase
> --------------------------------------------------
>
>                 Key: MAPREDUCE-6642
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-6642
>             Project: Hadoop Map/Reduce
>          Issue Type: Improvement
>          Components: test
>            Reporter: Akira AJISAKA
>            Priority: Minor
>
> After migrating to JUnit4, 
> {code:title=HadoopTestCase.java}
>   public HadoopTestCase(int mrMode, int fsMode, int taskTrackers, int dataNodes)
> {code}
> the above constructor can be changed to a configure method and call it from @BeforeClass
method of the subclasses. That way we can make the test more simple.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message