hadoop-mapreduce-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MAPREDUCE-5227) JobTrackerMetricsSource and QueueMetrics should standardize naming rules
Date Sat, 02 May 2015 18:29:06 GMT

    [ https://issues.apache.org/jira/browse/MAPREDUCE-5227?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14525393#comment-14525393
] 

Hadoop QA commented on MAPREDUCE-5227:
--------------------------------------

\\
\\
| (x) *{color:red}-1 overall{color}* |
\\
\\
|| Vote || Subsystem || Runtime || Comment ||
| {color:red}-1{color} | patch |   0m  0s | The patch command could not apply the patch during
dryrun. |
\\
\\
|| Subsystem || Report/Notes ||
| Patch URL | http://issues.apache.org/jira/secure/attachment/12582492/MAPREDUCE-5227-branch-1.1.patch
|
| Optional Tests | javadoc javac unit findbugs checkstyle |
| git revision | branch-1 / 5f5138e |
| Console output | https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/5594/console |


This message was automatically generated.

> JobTrackerMetricsSource and QueueMetrics should standardize naming rules
> ------------------------------------------------------------------------
>
>                 Key: MAPREDUCE-5227
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-5227
>             Project: Hadoop Map/Reduce
>          Issue Type: Improvement
>          Components: mrv1
>    Affects Versions: 1.1.3, 1.2.1
>            Reporter: Tsuyoshi Ozawa
>            Assignee: Tsuyoshi Ozawa
>            Priority: Minor
>         Attachments: MAPREDUCE-5227-1.1-branch.1.patch, MAPREDUCE-5227-branch-1.1.patch,
MAPREDUCE-5227.1.patch
>
>
> JobTrackerMetricsSource and QueueMetrics provides users with some metrics, but its naming
rules( "jobs_running", "running_maps", "running_reduces") sometimes confuses users. It should
be standardized.
> One concern is backward compatibility, so one idea is to share MetricMutableGaugeInt
object from old and new property name.
> e.g. to share runningMaps from "running_maps" and "maps_running".



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message