hadoop-mapreduce-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Karthik Kambatla (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MAPREDUCE-6267) Refactor JobSubmitter#copyAndConfigureFiles into it's own class
Date Wed, 04 Mar 2015 22:41:38 GMT

    [ https://issues.apache.org/jira/browse/MAPREDUCE-6267?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14347712#comment-14347712
] 

Karthik Kambatla commented on MAPREDUCE-6267:
---------------------------------------------

Looks good. +1.

Committing this. 

> Refactor JobSubmitter#copyAndConfigureFiles into it's own class
> ---------------------------------------------------------------
>
>                 Key: MAPREDUCE-6267
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-6267
>             Project: Hadoop Map/Reduce
>          Issue Type: Improvement
>            Reporter: Chris Trezzo
>            Assignee: Chris Trezzo
>            Priority: Minor
>         Attachments: MAPREDUCE-6267-trunk-v1.patch
>
>
> Refactor the uploading logic in JobSubmitter#copyAndConfigureFiles into it's own class.
This makes the JobSubmitter class more readable and isolates the logic that is actually uploading
the job resources to HDFS.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message