hadoop-mapreduce-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Manu Zhang (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MAPREDUCE-5993) native-task: simplify/remove dead code
Date Thu, 07 Aug 2014 03:40:12 GMT

    [ https://issues.apache.org/jira/browse/MAPREDUCE-5993?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14088767#comment-14088767

Manu Zhang commented on MAPREDUCE-5993:

Hi Todd, as the above is fixed in MAPREDUCE-6000, any other parts which you suspect is dead
code or could be simplified ?

> native-task: simplify/remove dead code
> --------------------------------------
>                 Key: MAPREDUCE-5993
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-5993
>             Project: Hadoop Map/Reduce
>          Issue Type: Sub-task
>          Components: task
>            Reporter: Todd Lipcon
> The native task code has a bunch of code in it which isn't related to the map output
collector. I suspect much if this is dead code. Let's remove it before we merge, so that the
amount of code we have to maintain going forward is more limited.

This message was sent by Atlassian JIRA

View raw message