hadoop-mapreduce-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "chaitali gupta (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MAPREDUCE-5016) GridMix Error: Found no satisfactory file in path
Date Tue, 13 May 2014 20:37:15 GMT

    [ https://issues.apache.org/jira/browse/MAPREDUCE-5016?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13996872#comment-13996872
] 

chaitali gupta commented on MAPREDUCE-5016:
-------------------------------------------

I also ran into similar issue earlier. the reason for this error is that - you are generating
20m of input. Gridmix code, when runs traces, looks for input data files that have more than
128mb in size. So if  you generate 20m of data, file filter search does not find any input
> 128mb of size. Hence, the error. 

THe fix is to add a config parameter to the gridmix command - "-Dgridmix.min.file.size= <MIN_SIZE>".
Hope this helps. 

> GridMix Error:  Found no satisfactory file in path 
> ---------------------------------------------------
>
>                 Key: MAPREDUCE-5016
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-5016
>             Project: Hadoop Map/Reduce
>          Issue Type: Bug
>          Components: contrib/gridmix
>    Affects Versions: 1.1.0, 1.1.1, 2.0.3-alpha
>         Environment: Ubuntu 12.04
>            Reporter: Light 
>
> Hello,
> Everytime i launch gridmix with the command:
> PAPATH=/home/light/Bureau/test_gridmix
> bin/hadoop -classpath $JAR_CLASSPATH org.apache.hadoop.mapred.gridmix.Gridmix  -Dgridmix.min.file.size=10m
-Dgridmix.output.directory=/home/light/Bureau/test -generate 20m $PAPATH /home/light/Bureau/test_rumen_output/job-trace.json
> I have this: Found no satisfactory file in /home/light/Bureau/test_gridmix
> This happen even if i use a hdfs path.
> I have exactly the same problem at first than [MAPREDUCE-2015|https://issues.apache.org/jira/browse/MAPREDUCE-2015]
(File already exist) and finish by having the same problem once my path problem was solved.

> What is bugging me:
> First: GRIDMIX_GENDATA (job_local_0001) success, even if it says it's a succes, in my
folder i only have a _SUCCESS file of size 0.
> I added some wait at this point in GridMix and juste before the check, there is no file
in the output folder.
> Second: Whatever the size asked it will do it in 1s, so i think the problem may be here:
There is a bug for me, no file is generated.
> I tried with every hadoop version and none of them is working.
> Here is the output:
> 13/02/20 14:42:47 INFO gridmix.SubmitterUserResolver:  Current user resolver is SubmitterUserResolver

> 13/02/20 14:42:47 WARN gridmix.Gridmix: Resource null ignored
> 13/02/20 14:42:47 WARN util.NativeCodeLoader: Unable to load native-hadoop library for
your platform... using builtin-java classes where applicable
> 13/02/20 14:42:47 INFO gridmix.Gridmix:  Submission policy is STRESS
> 13/02/20 14:42:47 INFO gridmix.Gridmix: Generating 20,0m of test data...
> 13/02/20 14:42:47 INFO gridmix.Statistics: Not tracking job GRIDMIX_GENDATA as seq id
is less than zero: -1
> 13/02/20 14:42:52 INFO gridmix.JobMonitor: GRIDMIX_GENDATA (job_local_0001) success
> 13/02/20 14:42:57 INFO gridmix.Gridmix: Changing the permissions for inputPath /home/light/Bureau/test_gridmix
> 13/02/20 14:42:57 INFO gridmix.Gridmix: Done.
> 13/02/20 14:44:12 ERROR gridmix.Gridmix: Startup failed
> java.io.IOException: Found no satisfactory file in /home/light/Bureau/test_gridmix
> 	at org.apache.hadoop.mapred.gridmix.FilePool.refresh(FilePool.java:105)
> 	at org.apache.hadoop.mapred.gridmix.JobSubmitter.refreshFilePool(JobSubmitter.java:159)
> 	at org.apache.hadoop.mapred.gridmix.Gridmix.start(Gridmix.java:291)
> 	at org.apache.hadoop.mapred.gridmix.Gridmix.runJob(Gridmix.java:264)
> 	at org.apache.hadoop.mapred.gridmix.Gridmix.access$000(Gridmix.java:55)
> 	at org.apache.hadoop.mapred.gridmix.Gridmix$1.run(Gridmix.java:217)
> 	at org.apache.hadoop.mapred.gridmix.Gridmix$1.run(Gridmix.java:215)
> 	at java.security.AccessController.doPrivileged(Native Method)
> 	at javax.security.auth.Subject.doAs(Subject.java:416)
> 	at org.apache.hadoop.security.UserGroupInformation.doAs(UserGroupInformation.java:1121)
> 	at org.apache.hadoop.mapred.gridmix.Gridmix.run(Gridmix.java:215)
> 	at org.apache.hadoop.util.ToolRunner.run(ToolRunner.java:65)
> 	at org.apache.hadoop.mapred.gridmix.Gridmix.main(Gridmix.java:395)
> 13/02/20 14:44:12 INFO gridmix.Gridmix: Exiting...
> Thanks in advance for any responses
>  



--
This message was sent by Atlassian JIRA
(v6.2#6252)

Mime
View raw message