hadoop-mapreduce-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Arun C Murthy (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MAPREDUCE-5311) Replace SLOTS_MILLIS counters with MEM_MILLIS
Date Thu, 15 Aug 2013 04:45:49 GMT

    [ https://issues.apache.org/jira/browse/MAPREDUCE-5311?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13740671#comment-13740671

Arun C Murthy commented on MAPREDUCE-5311:

I'll repeat that I'm against multiple configs for the same property which leads to operator
errors (admins setting one but forgetting to set the other) and am willing to live with other
alternatives which seem better from a technical standpoint.

bq. Why we don't use the Hadoop 1 JT properties for the same, in the mapred-site.xml documenting
how they have to be set to the MIN of the scheduler for SLOT_MILLIS counter to kick in? To
me this seem a much more correct way of doing it.

ATM, I don't see where this argument is going at all - frankly, we seem to be making YARN-1004
much bigger deal than it is.

Several folks have expressed concerns about multiple configs and yet we don't seem to converge;
this is in spite of, IMO, very reasonable alternatives. 

I'm inclined to go ahead with rc2 without this & YARN-1004. We can revisit both for 2.1.1
via deprecation of properties in YARN-1004 etc. if necessary.

My plan is to cut an rc2 by noon PST tmrw (9/15). Let's revisit this after if we can agree
today. Thanks.
> Replace SLOTS_MILLIS counters with MEM_MILLIS
> ---------------------------------------------
>                 Key: MAPREDUCE-5311
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-5311
>             Project: Hadoop Map/Reduce
>          Issue Type: Bug
>          Components: applicationmaster
>    Affects Versions: 2.0.4-alpha
>            Reporter: Alejandro Abdelnur
>            Assignee: Sandy Ryza
>            Priority: Blocker
>             Fix For: 2.1.0-beta
>         Attachments: MAPREDUCE-5311-1.patch, MAPREDUCE-5311.patch, MAPREDUCE-5311.patch
> Per discussion in MAPREDUCE-5310 and comments in the code we should remove all the related
logic and just leave the counter constant for backwards compatibility and deprecate the counter

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

View raw message