hadoop-mapreduce-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Pranay Varma (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (MAPREDUCE-5347) getBlacklistedTrackers() should be deprecated and a new method called getNumBlacklistedTrackers should be added.
Date Sun, 23 Jun 2013 00:30:20 GMT

     [ https://issues.apache.org/jira/browse/MAPREDUCE-5347?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Pranay Varma updated MAPREDUCE-5347:
------------------------------------

    Description: 
If the method returns a number, then that is what the method name should reflect. It should
be called getNumBlacklistedTrackers(). The method does not return trackers, it returns number
of trackers.

The same applies to the following:
- getMapTasks, getReduceTasks, getTaskTrackers

These should be deprecated and a new method should be added: getNumxxx. 

  was:
If the method returns a number, then that is what the method name should reflect. It should
be called getNumBlacklistedTrackers();

The same applies to the following:
- getMapTasks, getReduceTasks, getTaskTrackers

These should be deprecated and a new method should be added: getNumxxx. 

        Summary: getBlacklistedTrackers() should be deprecated and a new method called  getNumBlacklistedTrackers
should be added.   (was: getBlacklistedTrackers() is misleading. It does not return trackers.
It should be renamed getNumBlacklistedTrackers. )
    
> getBlacklistedTrackers() should be deprecated and a new method called  getNumBlacklistedTrackers
should be added. 
> ------------------------------------------------------------------------------------------------------------------
>
>                 Key: MAPREDUCE-5347
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-5347
>             Project: Hadoop Map/Reduce
>          Issue Type: Bug
>          Components: contrib/streaming, documentation
>    Affects Versions: 2.1.0-beta, 2.0.5-alpha
>            Reporter: Pranay Varma
>
> If the method returns a number, then that is what the method name should reflect. It
should be called getNumBlacklistedTrackers(). The method does not return trackers, it returns
number of trackers.
> The same applies to the following:
> - getMapTasks, getReduceTasks, getTaskTrackers
> These should be deprecated and a new method should be added: getNumxxx. 

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message