hadoop-mapreduce-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Karthik Kambatla (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MAPREDUCE-5304) mapreduce.Job killTask/failTask/getTaskCompletionEvents methods have incompatible signature changes
Date Thu, 06 Jun 2013 00:30:21 GMT

    [ https://issues.apache.org/jira/browse/MAPREDUCE-5304?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13676537#comment-13676537
] 

Karthik Kambatla commented on MAPREDUCE-5304:
---------------------------------------------

Thanks [~zjshen] for your inputs. I agree on the confusing naming (even I found it confusing),
but I basically picked the name from the method in ClientProtocol. Also, the newly added method
is annotated @Private, so end-users shouldn't be using it. I can change the name if you insist;
otherwise, I ll leave it consistent with ClientProtocol. What do you think?

I was under the impression that we are prioritizing 1.0 -> 2.0 compatibility over 0.23
-> 2.0 compatibility. Correct me if I am wrong. If the decision has not been made, it might
be better to discuss it on the mailing list so everyone knows.

                
> mapreduce.Job killTask/failTask/getTaskCompletionEvents methods have incompatible signature
changes
> ---------------------------------------------------------------------------------------------------
>
>                 Key: MAPREDUCE-5304
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-5304
>             Project: Hadoop Map/Reduce
>          Issue Type: Sub-task
>    Affects Versions: 2.0.4-alpha
>            Reporter: Alejandro Abdelnur
>            Assignee: Karthik Kambatla
>            Priority: Blocker
>         Attachments: mr-5304-1.patch
>
>
> Pointed out by [~zjshen] in MAPREDUCE-4942.
> In {{o.a.h.mapreduce.Job}} class, the following changed from Hadoop 1 to Hadoop 2.
> boolean failTask(TaskAttemptID): Change in return type from void to boolean.
> boolean killTask(TaskAttemptID): Change in return type from void to boolean.
> TaskCompletionEvent[] getTaskCompletionEvents(int): Change in return type from org.apache.hadoop.mapred.TaskCompletionEvent[]
to org.apache.hadoop.mapreduce.TaskCompletionEvent[].
> Using same rational as in other JIRAs, we should fix this to ensure Hadoop 1 to Hadoop
2 source compatibility (taking 0.23.x releases as a casualty as there is not right way for
everybody because we screwed up :( ). Flagging it as incompatible change because of 0.23.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message