hadoop-mapreduce-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alejandro Abdelnur (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (MAPREDUCE-5304) mapreduce.Job killTask/failTask/getTaskCompletionEvents methods have incompatible signature changes
Date Wed, 12 Jun 2013 18:54:20 GMT

     [ https://issues.apache.org/jira/browse/MAPREDUCE-5304?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Alejandro Abdelnur updated MAPREDUCE-5304:
------------------------------------------

       Resolution: Fixed
    Fix Version/s: 2.1.0-beta
     Hadoop Flags: Incompatible change,Reviewed  (was: Incompatible change)
           Status: Resolved  (was: Patch Available)

Thanks Karthik. Committed to trunk, branch-2 and branch-2.1-beta.
                
> mapreduce.Job killTask/failTask/getTaskCompletionEvents methods have incompatible signature
changes
> ---------------------------------------------------------------------------------------------------
>
>                 Key: MAPREDUCE-5304
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-5304
>             Project: Hadoop Map/Reduce
>          Issue Type: Sub-task
>    Affects Versions: 2.0.4-alpha
>            Reporter: Alejandro Abdelnur
>            Assignee: Karthik Kambatla
>            Priority: Blocker
>             Fix For: 2.1.0-beta
>
>         Attachments: mr-5304-1.patch
>
>
> Pointed out by [~zjshen] in MAPREDUCE-4942.
> In {{o.a.h.mapreduce.Job}} class, the following changed from Hadoop 1 to Hadoop 2.
> boolean failTask(TaskAttemptID): Change in return type from void to boolean.
> boolean killTask(TaskAttemptID): Change in return type from void to boolean.
> TaskCompletionEvent[] getTaskCompletionEvents(int): Change in return type from org.apache.hadoop.mapred.TaskCompletionEvent[]
to org.apache.hadoop.mapreduce.TaskCompletionEvent[].
> Using same rational as in other JIRAs, we should fix this to ensure Hadoop 1 to Hadoop
2 source compatibility (taking 0.23.x releases as a casualty as there is not right way for
everybody because we screwed up :( ). Flagging it as incompatible change because of 0.23.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message