hadoop-mapreduce-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tsuyoshi OZAWA (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (MAPREDUCE-5227) JobTrackerMetricsSource and QueueMetrics should standardize naming rules
Date Thu, 09 May 2013 16:39:17 GMT

     [ https://issues.apache.org/jira/browse/MAPREDUCE-5227?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Tsuyoshi OZAWA updated MAPREDUCE-5227:

    Attachment: MAPREDUCE-5227-branch-1.1.patch

Fixed typo.
> JobTrackerMetricsSource and QueueMetrics should standardize naming rules
> ------------------------------------------------------------------------
>                 Key: MAPREDUCE-5227
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-5227
>             Project: Hadoop Map/Reduce
>          Issue Type: Improvement
>          Components: mrv1
>    Affects Versions: 1.1.3, 1.2.1
>            Reporter: Tsuyoshi OZAWA
>            Assignee: Tsuyoshi OZAWA
>            Priority: Minor
>         Attachments: MAPREDUCE-5227-1.1-branch.1.patch, MAPREDUCE-5227.1.patch, MAPREDUCE-5227-branch-1.1.patch
> JobTrackerMetricsSource and QueueMetrics provides users with some metrics, but its naming
rules( "jobs_running", "running_maps", "running_reduces") sometimes confuses users. It should
be standardized.
> One concern is backward compatibility, so one idea is to share MetricMutableGaugeInt
object from old and new property name.
> e.g. to share runningMaps from "running_maps" and "maps_running".

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

View raw message