hadoop-mapreduce-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Joseph Evans (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MAPREDUCE-4888) NLineInputFormat drops data in 1.1 and beyond
Date Thu, 20 Dec 2012 17:23:14 GMT

    [ https://issues.apache.org/jira/browse/MAPREDUCE-4888?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13537173#comment-13537173
] 

Robert Joseph Evans commented on MAPREDUCE-4888:
------------------------------------------------

But that is very minor and I would not want it to stop this from going in.
                
> NLineInputFormat drops data in 1.1 and beyond
> ---------------------------------------------
>
>                 Key: MAPREDUCE-4888
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-4888
>             Project: Hadoop Map/Reduce
>          Issue Type: Bug
>          Components: mrv1
>    Affects Versions: 1.1.0
>            Reporter: Robert Joseph Evans
>            Assignee: Vinod Kumar Vavilapalli
>            Priority: Blocker
>         Attachments: MAPREDUCE-4888-20121219.txt, test.patch
>
>
> When trying to root cause why MAPREDUCE-4782 did not cause us issues on 1.0.2, I found
out that HADOOP-7823 introduced essentially the exact same error into org.apache.hadoop.mapred.lib.NLineInputFormat.
> In 1.X org.apache.hadoop.mapred.lib.NLineInputFormat and org.apache.hadoop.mapreduce.lib.input.NLineInputFormat
are separate implementations.  The latter had an off by one error in it until MAPREDUCE-4782
fixed it. The former had no error in it until HADOOP-7823 introduced it in 1.1 and MAPREDUCE-375
combined the implementations together but picked the implementation with the off by one error
in 0.21.
> I will attach a patch that exposes the error.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message