hadoop-mapreduce-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alejandro Abdelnur (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MAPREDUCE-4812) Create reduce input merger plugin in ReduceTask.java and pass it to Shuffle
Date Wed, 21 Nov 2012 18:11:58 GMT

    [ https://issues.apache.org/jira/browse/MAPREDUCE-4812?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13502167#comment-13502167
] 

Alejandro Abdelnur commented on MAPREDUCE-4812:
-----------------------------------------------

Asokan, it looks good. Similar to what has been suggested/done in MAPREDUCE-4049 the MergerManager.initialize()
method should receive a context with all parameter. This Context could be a static inner class
in the  ReduceInputMerger interface. Also the initialize() method should be renamed to init()
to be consistent with the shuffle plugin.
                
> Create reduce input merger plugin in ReduceTask.java and pass it to Shuffle
> ---------------------------------------------------------------------------
>
>                 Key: MAPREDUCE-4812
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-4812
>             Project: Hadoop Map/Reduce
>          Issue Type: Sub-task
>    Affects Versions: 2.0.2-alpha
>            Reporter: Mariappan Asokan
>            Assignee: Mariappan Asokan
>             Fix For: 2.0.3-alpha
>
>         Attachments: mapreduce-4812.patch
>
>
> This is part of MAPREDUCE-2454.  This further breaks down MAPREDUCE-4808

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message