hadoop-mapreduce-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Joseph Evans (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (MAPREDUCE-4562) Support for "FileSystemCounter" legacy counter group name for compatibility reasons is creating incorrect counter name
Date Thu, 16 Aug 2012 14:10:38 GMT

     [ https://issues.apache.org/jira/browse/MAPREDUCE-4562?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Robert Joseph Evans updated MAPREDUCE-4562:

    Fix Version/s: 0.23.3

Great Catch Jarek, I pulled this into 0.23.3 too.
> Support for "FileSystemCounter" legacy counter group name for compatibility reasons is
creating incorrect counter name
> ----------------------------------------------------------------------------------------------------------------------
>                 Key: MAPREDUCE-4562
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-4562
>             Project: Hadoop Map/Reduce
>          Issue Type: Bug
>    Affects Versions: 0.23.0, 0.23.1, 2.0.0-alpha
>            Reporter: Jarek Jarcec Cecho
>            Assignee: Jarek Jarcec Cecho
>             Fix For: 0.23.3, 2.1.0-alpha
>         Attachments: MAPREDUCE-4562.patch, MAPREDUCE-4562.patch
> Hi Guys,
> I was investigating issue in Sqoop project(http://sqoop.apache.org/). Problem is that
we are reporting number of written filesystem bytes back to the user and on Hadoop 0.23/2.x
we're always getting 0. I've noticed that there was some refactorization in FileSystem counter
related code and found MAPREDUCE-3542 requesting backward compatibility.
> Included patch seems to be adding counter "FileSystemCounter":
> {code:title=hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapreduce/counters/AbstractCounters.java:84}
> legacyMap.put("FileSystemCounter", FileSystemCounter.class.getName());
> {code}
> But it appears that original name is "FileSystemCounters" (Notice the plural "s" at the
end of name):
> {code:title=src/mapred/org/apache/hadoop/mapred/Task.java:91 (0.20.2)}
> protected static final String FILESYSTEM_COUNTER_GROUP = "FileSystemCounters";
> {code}
> {code:title=src/mapred/org/apache/hadoop/mapred/Task.java:109 (1.0.3)}
> protected static final String FILESYSTEM_COUNTER_GROUP = "FileSystemCounters";
> {code}
> I therefore believe that this counter should be renamed in order to provide backward
compatibility. I might fix this discrepancy in Sqoop, but I believe that other projects/users
might also be affected and therefore it would be better to fix it in upstream.

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira


View raw message