hadoop-mapreduce-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jarek Jarcec Cecho (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MAPREDUCE-3542) Support "FileSystemCounter" legacy counter group name for compatibility
Date Mon, 13 Aug 2012 08:05:38 GMT

    [ https://issues.apache.org/jira/browse/MAPREDUCE-3542?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13432987#comment-13432987
] 

Jarek Jarcec Cecho commented on MAPREDUCE-3542:
-----------------------------------------------

Hi Guys,
I was investigating related issue in Sqoop  project(http://sqoop.apache.org/). Basically we
are reporting number of written filesystem bytes back to the user and on Hadoop 0.23/2.x we're
always getting 0. I've noticed that there was some refactorization in FileSystem counter related
code and found this issue requesting backward compatibility. 

Included patch seems to be adding counter "FileSystemCounter":

{code:title=hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapreduce/counters/AbstractCounters.java:84}
legacyMap.put("FileSystemCounter", FileSystemCounter.class.getName());
{code}

But it appears that original name is "FileSystemCounters" (Notice the plural "s" at the end
of name):

{code:title=src/mapred/org/apache/hadoop/mapred/Task.java:91 (0.20.2)}
protected static final String FILESYSTEM_COUNTER_GROUP = "FileSystemCounters";
{code}

{code:title=src/mapred/org/apache/hadoop/mapred/Task.java:109 (1.0.3)}
protected static final String FILESYSTEM_COUNTER_GROUP = "FileSystemCounters";
{code}

I therefore believe that this counter should be renamed in order to provide backward compatibility.
I might fix this discrepancy in Sqoop, but I believe that other projects/users might also
be affected and therefore it would be better to fix it in upstream. I wanted to reopen this
ticket, but apparently I do not have enough privileges to do so. Could I ask anyone with proper
privileges to do that or should I create new JIRA instead?

                
> Support "FileSystemCounter" legacy counter group name for compatibility
> -----------------------------------------------------------------------
>
>                 Key: MAPREDUCE-3542
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-3542
>             Project: Hadoop Map/Reduce
>          Issue Type: Bug
>    Affects Versions: 0.23.0
>            Reporter: Tom White
>            Assignee: Tom White
>             Fix For: 0.23.1
>
>         Attachments: MAPREDUCE-3542.patch
>
>
> The group name changed from "FileSystemCounter" to "org.apache.hadoop.mapreduce.FileSystemCounter",
but we should support the old one for compatibility's sake. This came up in PIG-2347. 

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message