hadoop-mapreduce-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hadoop QA (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MAPREDUCE-4562) Support for "FileSystemCounter" legacy counter group name for compatibility reasons is creating incorrect counter name
Date Thu, 16 Aug 2012 07:33:38 GMT

    [ https://issues.apache.org/jira/browse/MAPREDUCE-4562?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13435810#comment-13435810
] 

Hadoop QA commented on MAPREDUCE-4562:
--------------------------------------

-1 overall.  Here are the results of testing the latest attachment 
  http://issues.apache.org/jira/secure/attachment/12541188/MAPREDUCE-4562.patch
  against trunk revision .

    +1 @author.  The patch does not contain any @author tags.

    +1 tests included.  The patch appears to include 1 new or modified test files.

    +1 javac.  The applied patch does not increase the total number of javac compiler warnings.

    +1 javadoc.  The javadoc tool did not generate any warning messages.

    +1 eclipse:eclipse.  The patch built with eclipse:eclipse.

    +1 findbugs.  The patch does not introduce any new Findbugs (version 1.3.9) warnings.

    +1 release audit.  The applied patch does not increase the total number of release audit
warnings.

    -1 core tests.  The patch failed these unit tests in hadoop-mapreduce-project/hadoop-mapreduce-client/hadoop-mapreduce-client-core:

                  org.apache.hadoop.mapred.TestCounters

    +1 contrib tests.  The patch passed contrib unit tests.

Test results: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/2743//testReport/
Console output: https://builds.apache.org/job/PreCommit-MAPREDUCE-Build/2743//console

This message is automatically generated.
                
> Support for "FileSystemCounter" legacy counter group name for compatibility reasons is
creating incorrect counter name
> ----------------------------------------------------------------------------------------------------------------------
>
>                 Key: MAPREDUCE-4562
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-4562
>             Project: Hadoop Map/Reduce
>          Issue Type: Bug
>    Affects Versions: 0.23.0, 0.23.1, 2.0.0-alpha
>            Reporter: Jarek Jarcec Cecho
>         Attachments: MAPREDUCE-4562.patch
>
>
> Hi Guys,
> I was investigating issue in Sqoop project(http://sqoop.apache.org/). Problem is that
we are reporting number of written filesystem bytes back to the user and on Hadoop 0.23/2.x
we're always getting 0. I've noticed that there was some refactorization in FileSystem counter
related code and found MAPREDUCE-3542 requesting backward compatibility.
> Included patch seems to be adding counter "FileSystemCounter":
> {code:title=hadoop-mapreduce-client-core/src/main/java/org/apache/hadoop/mapreduce/counters/AbstractCounters.java:84}
> legacyMap.put("FileSystemCounter", FileSystemCounter.class.getName());
> {code}
> But it appears that original name is "FileSystemCounters" (Notice the plural "s" at the
end of name):
> {code:title=src/mapred/org/apache/hadoop/mapred/Task.java:91 (0.20.2)}
> protected static final String FILESYSTEM_COUNTER_GROUP = "FileSystemCounters";
> {code}
> {code:title=src/mapred/org/apache/hadoop/mapred/Task.java:109 (1.0.3)}
> protected static final String FILESYSTEM_COUNTER_GROUP = "FileSystemCounters";
> {code}
> I therefore believe that this counter should be renamed in order to provide backward
compatibility. I might fix this discrepancy in Sqoop, but I believe that other projects/users
might also be affected and therefore it would be better to fix it in upstream.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message