hadoop-mapreduce-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kihwal Lee (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MAPREDUCE-4416) Some tests fail if Clover is enabled
Date Wed, 11 Jul 2012 09:48:34 GMT

    [ https://issues.apache.org/jira/browse/MAPREDUCE-4416?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13411354#comment-13411354
] 

Kihwal Lee commented on MAPREDUCE-4416:
---------------------------------------

The failing tests are using MiniMRCluster and submit jobs. Jobs fail because containers' classpath
does not contain the clover jar. If I make the leaf project to pick up non-clovered mr-client-app,
at least AM works. But custom mapper, reducers, etc. defined in mr-client-jobclient will be
instrumented and be part of the code running inside containers, so the containers should be
able to locate the clover jar.

We have a record of these tests working with clover at least on June 24. So I went back and
tried the old revision but it didn't work this time...  I wonder how it ever worked. 

Before MAPREDUCE-4082, it seems the classpath in mr-client-app contained the clover jar. The
jira comments also shows clover being in the generated classpath. The now problematic clovered
tests might have worked okay back then.  Some tests were also being ignored.

There is MAPREDUCE-4141 that removed the hard dependency on clover. If these tests accidentally
worked before, this might have stopped it. 

Maybe running clovered test code in yarn containers does not make sense. They are separate
processes launched by something other than the test framework. The clover instrumentation
doesn't seem to be designed to naturally cover them. We could exclude some of test helper
classes from instrumentation.
                
> Some tests fail if Clover is enabled
> ------------------------------------
>
>                 Key: MAPREDUCE-4416
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-4416
>             Project: Hadoop Map/Reduce
>          Issue Type: Bug
>          Components: client, mrv2
>    Affects Versions: 2.0.0-alpha, 3.0.0
>            Reporter: Kihwal Lee
>            Priority: Critical
>             Fix For: 2.0.1-alpha, 3.0.0
>
>
> There are number of tests running under hadoop-mapreduce-client-jobclient that fail if
Clover is enabled. Whenever a job is launched, AM doesn't start because it can't locate the
clover jar file.
> It seems this started happening after MAPREDUCE-4253.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message