hadoop-mapreduce-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bhallamudi Venkata Siva Kamesh (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MAPREDUCE-4080) FileNotFoundException while accessing job configuration from UI.
Date Thu, 29 Mar 2012 13:48:27 GMT

    [ https://issues.apache.org/jira/browse/MAPREDUCE-4080?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13241231#comment-13241231
] 

Bhallamudi Venkata Siva Kamesh commented on MAPREDUCE-4080:
-----------------------------------------------------------

This is because of the *stale* object returned from the *loadedJobCache*.

When I tried to access the job config first time, when job history files were present in the
intermediate directory, as *loadedJobCache* does not contain any entries to fulfill the request,
CompletedJob object was created and has been added to *loadedJobCache* and the same object
has been returned. However when I tried to access the same job config again, this time job
history files were present in the done directory, as *loadedJobCache* already contained the
job entry, *loadedJobCache* returned the job object from its cache. So the returned job object's
confFile path pointing to *intermediate* directory where as the job's actual confFile is present
inside done directory and hence the exception.
                
> FileNotFoundException while accessing job configuration from UI.
> ----------------------------------------------------------------
>
>                 Key: MAPREDUCE-4080
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-4080
>             Project: Hadoop Map/Reduce
>          Issue Type: Bug
>          Components: jobhistoryserver, mrv2
>    Affects Versions: 2.0.0, trunk
>            Reporter: Bhallamudi Venkata Siva Kamesh
>            Priority: Critical
>
> Tried to access the job configuration from UI, when the job history files were still
in the intermediate directory. JHS displayed the configurations of the job. Again tried to
access the configurations of the same job, when the job history files were in the done directory.
This time got the following exception
> {noformat}
> java.io.FileNotFoundException: File does not exist: /jobhistory/intermediate/kamesh/job_1332999698561_0005_conf.xml
> 	at org.apache.hadoop.hdfs.server.namenode.FSNamesystem.getBlockLocationsUpdateTimes(FSNamesystem.java:1153)
> 	at org.apache.hadoop.hdfs.server.namenode.FSNamesystem.getBlockLocations(FSNamesystem.java:1115)
> 	at org.apache.hadoop.hdfs.server.namenode.FSNamesystem.getBlockLocations(FSNamesystem.java:1087)
> {noformat}

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message