hadoop-mapreduce-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Siddharth Seth (Updated) (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (MAPREDUCE-2793) [MR-279] Maintain consistency in naming appIDs, jobIDs and attemptIDs
Date Wed, 22 Feb 2012 22:07:49 GMT

     [ https://issues.apache.org/jira/browse/MAPREDUCE-2793?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Siddharth Seth updated MAPREDUCE-2793:

    Status: Open  (was: Patch Available)

TaskID and JobID forName currently seem to generate a single exception string only - irrespective
of the few if/else conditions. The patch is changing the exception message based on where
the exception occurs.
Irrespective of what the other code is doing - creating this extra string each time forName
is invoked can be avoided.
In fact any change to forName can be avoided if mrv2 JobId,TaskIds can be constructed from
string directly. A separate implementation of forName for mrv2 types.
> [MR-279] Maintain consistency in naming appIDs, jobIDs and attemptIDs 
> ----------------------------------------------------------------------
>                 Key: MAPREDUCE-2793
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-2793
>             Project: Hadoop Map/Reduce
>          Issue Type: Bug
>          Components: mrv2
>    Affects Versions: 0.23.0
>            Reporter: Ramya Sunil
>            Assignee: Bikas Saha
>            Priority: Critical
>             Fix For: 0.23.2
>         Attachments: MAPREDUCE-2793-branch-0.23.patch, MAPREDUCE-2793-branch-0.23.patch,
MAPREDUCE-2793-branch-0.23.patch, MAPREDUCE-2793-branch-0.23.patch, MAPREDUCE-2793-branch-0.23.patch,
> appIDs, jobIDs and attempt/container ids are not consistently named in the logs, console
and UI. For consistency purpose, they all have to follow a common naming convention.
> Currently, 
> For appID
> =========
> On the RM UI: app_1308259676864_5 
> On the JHS UI: No appID 
> Console/logs: No appID
> mapred-local dirs are named as: application_1308259676864_0005
> For jobID
> =========
> On the RM UI: job_1308259676864_5_5 
> JHS UI: job_1308259676864_5_5 
> Console/logs: job_1308259676864_0005
> mapred-local dirs are named as: No jobID
> For attemptID
> ============
> On the RM UI: attempt_1308259676864_5_5_m_24_0
> JHS attempt_1308259676864_5_5_m_24_0
> Console/logs: attempt_1308259676864_0005_m_000024_0
> mapred-local dirs are named as: container_1308259676864_0005_000024

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira


View raw message