hadoop-mapreduce-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bikas Saha (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MAPREDUCE-2793) [MR-279] Maintain consistency in naming appIDs, jobIDs and attemptIDs
Date Tue, 21 Feb 2012 23:58:48 GMT

    [ https://issues.apache.org/jira/browse/MAPREDUCE-2793?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13213122#comment-13213122

Bikas Saha commented on MAPREDUCE-2793:

The reason these failed was I removed the default exception string (per the review comments).
I forgot why I had put them there in the first place. The TaskId*.forName() code error path
is not simple. It has errors through exceptions and the if-else statement checks. Earlier
it would throw exceptions in multiple places with slightly different texts, as well as right
in the end. I removed the exceptions thrown everywhere else and used the one in the end as
the common one (to make the tests less flaky). Now this means, that the exception message
string must be properly generated for all error paths. That would have been easy had it only
been via exceptions. But there are if-else code paths that also produce errors.
End results is that I am going back to the default error strings. This might allocate an extra
string but it would be a very short lived allocation (so its easy for the GS is my guess)
and looking at the rest of the code makes me believe this extra allocation is not something
to worry about.
> [MR-279] Maintain consistency in naming appIDs, jobIDs and attemptIDs 
> ----------------------------------------------------------------------
>                 Key: MAPREDUCE-2793
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-2793
>             Project: Hadoop Map/Reduce
>          Issue Type: Bug
>          Components: mrv2
>    Affects Versions: 0.23.0
>            Reporter: Ramya Sunil
>            Assignee: Bikas Saha
>            Priority: Critical
>             Fix For: 0.23.2
>         Attachments: MAPREDUCE-2793-branch-0.23.patch, MAPREDUCE-2793-branch-0.23.patch,
MAPREDUCE-2793-branch-0.23.patch, MAPREDUCE-2793-branch-0.23.patch, MAPREDUCE-2793-branch-0.23.patch,
> appIDs, jobIDs and attempt/container ids are not consistently named in the logs, console
and UI. For consistency purpose, they all have to follow a common naming convention.
> Currently, 
> For appID
> =========
> On the RM UI: app_1308259676864_5 
> On the JHS UI: No appID 
> Console/logs: No appID
> mapred-local dirs are named as: application_1308259676864_0005
> For jobID
> =========
> On the RM UI: job_1308259676864_5_5 
> JHS UI: job_1308259676864_5_5 
> Console/logs: job_1308259676864_0005
> mapred-local dirs are named as: No jobID
> For attemptID
> ============
> On the RM UI: attempt_1308259676864_5_5_m_24_0
> JHS attempt_1308259676864_5_5_m_24_0
> Console/logs: attempt_1308259676864_0005_m_000024_0
> mapred-local dirs are named as: container_1308259676864_0005_000024

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira


View raw message