hadoop-mapreduce-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Karam Singh (Updated) (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (MAPREDUCE-3532) When 0 is provided as port number in yarn.nodemanager.webapp.address, NMs webserver component picks up random port, NM keeps on Reporting 0 port to RM
Date Mon, 12 Dec 2011 06:00:34 GMT

     [ https://issues.apache.org/jira/browse/MAPREDUCE-3532?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Karam Singh updated MAPREDUCE-3532:
-----------------------------------

    Summary: When 0 is provided as port number in yarn.nodemanager.webapp.address, NMs webserver
component picks up random port, NM keeps on Reporting 0 port to RM  (was: When 0 is provided
as port number in yarn.nodemanager.webapp.address, NMs webserver component picks up random
port, NM keeps on Reporting 0 port ot RM)
    
> When 0 is provided as port number in yarn.nodemanager.webapp.address, NMs webserver component
picks up random port, NM keeps on Reporting 0 port to RM
> ------------------------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: MAPREDUCE-3532
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-3532
>             Project: Hadoop Map/Reduce
>          Issue Type: Bug
>          Components: nodemanager
>    Affects Versions: 0.23.1
>            Reporter: Karam Singh
>
> I tried following -:
> yarn.nodemanager.address=0.0.0.0:0
> yarn.nodemanager.webapp.address=0.0.0.0:0
> yarn.nodemanager.localizer.address=0.0.0.0:0
> mapreduce.shuffle.port=0
> When 0 is provided as number in yarn.nodemanager.webapp.address. 
> NM instantiate WebServer as 0 piort e.g.
> {code}
> 2011-12-08 11:33:02,467 INFO org.apache.hadoop.yarn.server.nodemanager.webapp.WebServer:
Instantiating NMWebApp at 0.0.0.0:0
> {code}
> After that WebServer pick up some random port e.g.
> {code}
> 2011-12-08 11:33:02,562 INFO org.apache.hadoop.http.HttpServer: Jetty bound to port 36272
> 2011-12-08 11:33:02,562 INFO org.mortbay.log: jetty-6.1.26
> 2011-12-08 11:33:02,831 INFO org.mortbay.log: Started SelectChannelConnector@0.0.0.0:36272
> 2011-12-08 11:33:02,831 INFO org.apache.hadoop.yarn.webapp.WebApps: Web app /node started
at 36272
> {code}
> And NM WebServer responds correctly but
>  RM's cluster/Nodes page shows the following -:
> {code}
> /Rack RUNNING NM:57963 NM:0 Healthy 8-Dec-2011 11:33:01 Healthy 8 12 GB 0 KB
> {code}
> Whereas NM:0 is not clickable.
> Seems even NM's webserver pick random port but it never gets updated and so NM report
0 as HTTP port to RM causing NM Hyperlinks un-clickable
> But verified that MR job runs successfully with random.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message