hadoop-mapreduce-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "chackaravarthy (Commented) (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MAPREDUCE-3009) RM UI -> Applications -> Application(Job History) -> Map Tasks -> Task ID -> Node link is not working
Date Thu, 13 Oct 2011 14:34:12 GMT

    [ https://issues.apache.org/jira/browse/MAPREDUCE-3009?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13126620#comment-13126620
] 

chackaravarthy commented on MAPREDUCE-3009:
-------------------------------------------

:-) here url method internally using ujoin method which is being used in many places. 
And actually here now i feel like no need to use url method at all. 
simply ,

{code} td().a(".nodelink", "http://"+ nodeHttpAddr, nodeHttpAddr)._(); {code}

this may be enough i think. Because I see the similar usage for getting node link in NodesPage.java


{code} td().a("http://" + ni.getHttpAddress(), ni.getHttpAddress())._(). {code}

shall i proceed with simple concatenation or fixing the ujoin method?

Thanks
                
> RM UI -> Applications -> Application(Job History) -> Map Tasks -> Task ID
-> Node link is not working
> -----------------------------------------------------------------------------------------------------
>
>                 Key: MAPREDUCE-3009
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-3009
>             Project: Hadoop Map/Reduce
>          Issue Type: Bug
>          Components: jobhistoryserver, mrv2
>    Affects Versions: 0.23.0, 0.24.0
>            Reporter: chackaravarthy
>            Assignee: chackaravarthy
>             Fix For: 0.24.0
>
>         Attachments: IE_node_link_not_working.png, MAPREDUCE-3009-1.patch, MAPREDUCE-3009.patch,
chrome_node_link_working.png, invalid_url.png, invalid_url_latest_code.png
>
>
> RM UI -> Applications -> Application(Job History) -> Map Tasks -> Task ID
-> Node link is not working. The URL contains extra '/' which is causing the problem. Please
find in the attached screen shots.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message