hadoop-mapreduce-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "chackaravarthy (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MAPREDUCE-3009) RM UI -> Applications -> Application(Job History) -> Map Tasks -> Task ID -> Node link is not working
Date Mon, 19 Sep 2011 05:17:09 GMT

    [ https://issues.apache.org/jira/browse/MAPREDUCE-3009?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13107622#comment-13107622
] 

chackaravarthy commented on MAPREDUCE-3009:
-------------------------------------------

Steps to verify :
=================

RM UI -> Applications -> Application(Job History) -> Map Tasks -> Task ID

Here task attempt page will open.
In the page, click on node link.
Earlier it was not working.. Now it will work

change in HsTaskPage.java:
==========================

Earlier the URL it was linked in anchor tag was http:///nodeHttpAddr
but it should be http://nodeHttpAddr

It is because "http://" and nodeHttpAddr was passed as 2 strings to method 

url(String... parts) in View.java

It should be passed as single string to url method.
hence the change as 
before :        td().a(".nodelink", url("http://", nodeHttpAddr), nodeHttpAddr)._();
after the fix : td().a(".nodelink", url("http://"+ nodeHttpAddr), nodeHttpAddr)._();


> RM UI -> Applications -> Application(Job History) -> Map Tasks -> Task ID
-> Node link is not working
> -----------------------------------------------------------------------------------------------------
>
>                 Key: MAPREDUCE-3009
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-3009
>             Project: Hadoop Map/Reduce
>          Issue Type: Bug
>          Components: jobhistoryserver
>    Affects Versions: 0.23.0, 0.24.0
>            Reporter: chackaravarthy
>             Fix For: 0.24.0
>
>         Attachments: MAPREDUCE-3009.patch, invalid_url.png
>
>
> RM UI -> Applications -> Application(Job History) -> Map Tasks -> Task ID
-> Node link is not working. The URL contains extra '/' which is causing the problem. Please
find in the attached screen shots.

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message