hadoop-mapreduce-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Josh Wills (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MAPREDUCE-2633) MR-279: Add a getCounter(Enum) method to the Counters interface
Date Sun, 03 Jul 2011 22:05:22 GMT

    [ https://issues.apache.org/jira/browse/MAPREDUCE-2633?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13059287#comment-13059287

Josh Wills commented on MAPREDUCE-2633:

Thanks Arun-- re: Counters.getCounter(String), I'd be happy to implement the API that way-
what are the semantics of the String?

> MR-279: Add a getCounter(Enum) method to the Counters interface
> ---------------------------------------------------------------
>                 Key: MAPREDUCE-2633
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-2633
>             Project: Hadoop Map/Reduce
>          Issue Type: Improvement
>          Components: mrv2
>         Environment: All
>            Reporter: Josh Wills
>            Assignee: Josh Wills
>            Priority: Minor
>         Attachments: MAPREDUCE-2633.patch
> I'm fixing a few TODOs I came across in TaskAttemptImpl.java related to the fact that
the MRv2 Counters interface don't expose a getCounter(Enum) method for accessing a Counter
using the enum's class as the group name and the enum's value as the name of the counter.
> Will add the patch momentarily.

This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira


View raw message