hadoop-mapreduce-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Owen O'Malley (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (MAPREDUCE-2506) Create a compatible interface for frameworks that need to clone MapReduce context objects.
Date Tue, 17 May 2011 21:15:47 GMT

     [ https://issues.apache.org/jira/browse/MAPREDUCE-2506?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Owen O'Malley updated MAPREDUCE-2506:
-------------------------------------

    Attachment: mr-2506.patch

> Create a compatible interface for frameworks that need to clone MapReduce context objects.
> ------------------------------------------------------------------------------------------
>
>                 Key: MAPREDUCE-2506
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-2506
>             Project: Hadoop Map/Reduce
>          Issue Type: Improvement
>            Reporter: Owen O'Malley
>         Attachments: mr-2506.patch
>
>
> In 0.21 we moved the org.apache.hadoop.mapreduce context objects to interfaces.
> That made the APIs much better, but broke backwards compatibility for frameworks that
need to clone them. 

--
This message is automatically generated by JIRA.
For more information on JIRA, see: http://www.atlassian.com/software/jira

Mime
View raw message