hadoop-mapreduce-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eli Collins (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (MAPREDUCE-1817) JT and TT should not have to match build versions
Date Thu, 27 May 2010 15:56:40 GMT

     [ https://issues.apache.org/jira/browse/MAPREDUCE-1817?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Eli Collins resolved MAPREDUCE-1817.
------------------------------------

    Resolution: Not A Problem

> JT and TT should not have to match build versions
> -------------------------------------------------
>
>                 Key: MAPREDUCE-1817
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-1817
>             Project: Hadoop Map/Reduce
>          Issue Type: Bug
>          Components: tasktracker
>    Affects Versions: 0.20.1, 0.20.2, 0.20.3, 0.21.0, 0.22.0
>            Reporter: Eli Collins
>             Fix For: 0.22.0
>
>
> TaskTracker#offerService checks for a match with the JT VersionInfo#getBuildVersion,
and fails if they are the same version but happen to be built at a different time of day.
It seems like the correct test is VersionInfo#getRevision.  fwiw the NN and DN do not have
to match build versions. 

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message