hadoop-mapreduce-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "rahul k singh (JIRA)" <j...@apache.org>
Subject [jira] Commented: (MAPREDUCE-1594) Support for Sleep Jobs in gridmix
Date Fri, 02 Apr 2010 03:54:27 GMT

    [ https://issues.apache.org/jira/browse/MAPREDUCE-1594?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12852690#action_12852690

rahul k singh commented on MAPREDUCE-1594:

I have implemented all the comments except 

-Structure wise, it would be better to rename GridmixJob to LoadJob, and create a common base
(probably should be abstract) class for LoadJob and SleepJob and call it GridmixJob that only
contains the shared parts of LoadJob and SleepJob. E.g. outdir may only belong to LoadJob
but not SleepJob. (BTW, are File{Input,Output}Format.set{Input,Output}Path needed for SleepJob.call()?)

GridmixJob is created as an abstract class , outdir has been pushed to GridmixJob as SleepJob
is also using this. We need File{Input,Output}Format.set{Input,Output}Path for mapreduce .
Iam not sure if this is a bug , but it is required.

> Support for Sleep Jobs in gridmix
> ---------------------------------
>                 Key: MAPREDUCE-1594
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-1594
>             Project: Hadoop Map/Reduce
>          Issue Type: New Feature
>          Components: contrib/gridmix
>            Reporter: rahul k singh
>         Attachments: 1594-yhadoop-20-1xx-1-2.patch, 1594-yhadoop-20-1xx-1.patch, 1594-yhadoop-20-1xx.patch
> Support for Sleep jobs in gridmix

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message