hadoop-mapreduce-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tom White (JIRA)" <j...@apache.org>
Subject [jira] Updated: (MAPREDUCE-1050) Introduce a mock object testing framework
Date Tue, 13 Oct 2009 15:51:31 GMT

     [ https://issues.apache.org/jira/browse/MAPREDUCE-1050?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Tom White updated MAPREDUCE-1050:

    Attachment: MAPREDUCE-1050.patch

Yes, the WithMocks suffix is optional, and shouldn't be usual practice - I only added it to
avoid naming conflicts. With this patch I've renamed TestLostTrackerWithMocks to TestLostTaskTracker,
but I've left TestMapReduceJobControlWithMocks alone for the moment. It can be renamed once
TestMapReduceJobControl is moved to the functional test hierarchy - this should go in another

(Within a hierarchy the name needs to be unique - even for tests in different packages - since
otherwise Eclipse has problems running all the tests in a hierarchy, I believe.)

> Introduce a mock object testing framework
> -----------------------------------------
>                 Key: MAPREDUCE-1050
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-1050
>             Project: Hadoop Map/Reduce
>          Issue Type: Test
>          Components: test
>            Reporter: Tom White
>            Assignee: Tom White
>         Attachments: MAPREDUCE-1050.patch, MAPREDUCE-1050.patch, MAPREDUCE-1050.patch
> Using mock objects in unit tests can improve code quality (see e.g. http://www.mockobjects.com/).
Hadoop would benefit from having a mock object framework for developers to write unit tests
with. Doing so will allow a wider range of failure conditions to be tested and the tests will
run faster.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message