hadoop-mapreduce-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jothi Padmanabhan (JIRA)" <j...@apache.org>
Subject [jira] Commented: (MAPREDUCE-947) OutputCommitter should have an abortJob method
Date Thu, 01 Oct 2009 04:39:23 GMT

    [ https://issues.apache.org/jira/browse/MAPREDUCE-947?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12761093#action_12761093

Jothi Padmanabhan commented on MAPREDUCE-947:

# Should not the _DONE directory be created only for successful jobs? In the patch, the default
implementation of abortJob calls cleanupJob, so _DONE will be created for failed/killed job
also, no? 
# The newly added file Utils should be called something like OutputFilterUtils or something
# There are unused imports in the test cases 
# The variable LOG in TestJobCleanup is not used 
# Do we really need a delayed setup for this test case? Could not we achieve the same using
a blocking mapper and then kill/fail the job? In such case, we may not need to rely on signaling
the setup job for completion. 
# The test case should also test for absence of _DONE folder for failed/killed jobs

> OutputCommitter should have an abortJob method
> ----------------------------------------------
>                 Key: MAPREDUCE-947
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-947
>             Project: Hadoop Map/Reduce
>          Issue Type: Improvement
>            Reporter: Owen O'Malley
>            Assignee: Amar Kamat
>             Fix For: 0.21.0
>         Attachments: mapred-948-v1.2.patch, mapred-948-v1.3.patch
> The OutputCommitter needs an abortJob method to clean up from failed jobs. Currently
there is no way to distinguish between failed or succeeded jobs, making it impossible to write
output promotion code.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message