hadoop-mapreduce-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "rahul k singh (JIRA)" <j...@apache.org>
Subject [jira] Updated: (MAPREDUCE-861) Modify queue configuration format and parsing to support a hierarchy of queues.
Date Thu, 03 Sep 2009 08:24:32 GMT

     [ https://issues.apache.org/jira/browse/MAPREDUCE-861?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

rahul k singh updated MAPREDUCE-861:

    Attachment: MAPREDUCE-861-3.patch

Additional changes

Changed JobSubmissionProtocol , introduced new public api , mentioned as part of MAPREDUCE
- 860.
Queue can only be accessed via its view.
JobQueueInfo is changed to have package private api to access properties.

Implemented all the comments except few:

existing implementation of populating acls is better as we need to again pass the node.

bq. getRoot() and getRootQueues() - confusing names. Atleast to me.
getRootQueues() is part of the interface exposed(860). So follows the same pattern.getRoot()
is a utility
method which is intended to be used in tests.

bq.  How about a new package Queues with all the queue related classes in the framework? Atleast
the new ones?
might be good idea to do it , but iam not including it in this jira.

bq.  There is a framework class HierarchyQueueBuilder and a CapacityScheduler class QueueHierarchyBuilder.
To avoid any confusion, can the later just be QueueBuilder or something like that?
think they are fine , as both class do generate the hierarchy.

> Modify queue configuration format and parsing to support a hierarchy of queues.
> -------------------------------------------------------------------------------
>                 Key: MAPREDUCE-861
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-861
>             Project: Hadoop Map/Reduce
>          Issue Type: Sub-task
>            Reporter: Hemanth Yamijala
>            Assignee: rahul k singh
>         Attachments: MAPREDUCE-861-1.patch, MAPREDUCE-861-2.patch, MAPREDUCE-861-3.patch
> MAPREDUCE-853 proposes to introduce a hierarchy of queues into the Map/Reduce framework.
This JIRA is for defining changes to the configuration related to queues. 
> The current format for defining a queue and its properties is as follows: mapred.queue.<queue-name>.<property-name>.
For e.g. mapred.queue.<queue-name>.acl-submit-job. The reason for using this verbose
format was to be able to reuse the Configuration parser in Hadoop. However, administrators
currently using the queue configuration have already indicated a very strong desire for a
more manageable format. Since, this becomes more unwieldy with hierarchical queues, the time
may be good to introduce a new format for representing queue configuration.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message