hadoop-mapreduce-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sharad Agarwal (JIRA)" <j...@apache.org>
Subject [jira] Commented: (MAPREDUCE-849) Renaming of configuration property names in mapreduce
Date Fri, 18 Sep 2009 07:24:57 GMT

    [ https://issues.apache.org/jira/browse/MAPREDUCE-849?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12757024#action_12757024

Sharad Agarwal commented on MAPREDUCE-849:

Glanced over the patch. Mostly looking fine. Some minor nits:
To be consistent let all properties start with TT_ in TTConfig. Similarly for JTConfig, all
should start from JT_
JTConfig.JT could have a better name
mapreduce.jobtracker.taskalloc.capacitypad is scheduler property. Should we rename it to mapreduce.jobtracker.scheduler.taskalloc.capacitypad
to be more clear
JTConfig.HOSTS and JTConfig.HOSTS_EXCLUDE takes file name. It will be better if we have that
in the name. Something like mapreduce.jobtracker.hosts.exclude.filename
In MRConfig, MAX_MAPMEMORY_MB and MAX_REDUCEMEMORY_MB are used only in jobtracker. so these
should be moved to JTConfig
I don't see any references of MRConfig.MAX_TRACKER_BLACKLISTS.

Also currently mapred-default.xml doesn't document all the properties. We should file a documentation
jira to add all missing properties in mapred-default.xml

> Renaming of configuration property names in mapreduce
> -----------------------------------------------------
>                 Key: MAPREDUCE-849
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-849
>             Project: Hadoop Map/Reduce
>          Issue Type: Improvement
>            Reporter: Amareshwari Sriramadasu
>            Assignee: Amareshwari Sriramadasu
>             Fix For: 0.21.0
>         Attachments: Config changes.xls, Config changes.xls, patch-849-1.txt, patch-849-2.txt,
> In-line with HDFS-531, property names in configuration files should be standardized in

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message