hadoop-mapreduce-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Harsh J (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (MAPREDUCE-104) Not able to refresh file cache
Date Tue, 03 Sep 2013 09:14:53 GMT

     [ https://issues.apache.org/jira/browse/MAPREDUCE-104?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel

Harsh J resolved MAPREDUCE-104.

    Resolution: Cannot Reproduce

This has gone stale. I tried running a test as described by Hairong, and I believe internal
tests too cover this, but no such error pops up. Probably fixed a long long time ago via other
DC changes/improvements. Resolving.
> Not able to refresh file cache
> ------------------------------
>                 Key: MAPREDUCE-104
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-104
>             Project: Hadoop Map/Reduce
>          Issue Type: Bug
>            Reporter: Hairong Kuang
>            Assignee: Mahadev konar
> I ran a map/reduce job with file caching. When I reran it with an updated file jar, I
got the following error :
> java.io.IOException: Cache XXX/hadoop/mapred/local/taskTracker/archive/YYY/input_data/cdxcore.Linux.jar
is in use and cannot be refreshed
> 	at org.apache.hadoop.filecache.DistributedCache.localizeCache(DistributedCache.java:195)
> 	at org.apache.hadoop.filecache.DistributedCache.getLocalCache(DistributedCache.java:86)
> 	at org.apache.hadoop.mapred.TaskRunner.run(TaskRunner.java:108)

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators
For more information on JIRA, see: http://www.atlassian.com/software/jira

View raw message