hadoop-mapreduce-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Harsh J (Resolved) (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (MAPREDUCE-3633) MAPREDUCE-1938 isn't present in 0.22 nor 0.23 nor trunk. Breaks API.
Date Fri, 06 Jan 2012 14:55:44 GMT

     [ https://issues.apache.org/jira/browse/MAPREDUCE-3633?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Harsh J resolved MAPREDUCE-3633.
--------------------------------

          Resolution: Invalid
    Target Version/s: 0.23.1, 0.22.1  (was: 0.22.1, 0.23.1)

Nevermind. This was an oversight, looking at some wrong sources.
                
> MAPREDUCE-1938 isn't present in 0.22 nor 0.23 nor trunk. Breaks API.
> --------------------------------------------------------------------
>
>                 Key: MAPREDUCE-3633
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-3633
>             Project: Hadoop Map/Reduce
>          Issue Type: Bug
>    Affects Versions: 0.22.0, 0.23.0
>            Reporter: Harsh J
>            Priority: Blocker
>
> MAPREDUCE-1938 introduced an API call in JobConf and the likes. This is not present in
0.22 nor 0.23.
> Even if it isn't needed, the method must be still present as @Deprecated and perhaps
made defunct inside if it should not do anything.
> Not having this method is API breakage.
> Let me know if am grossly wrong here.

--
This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators: https://issues.apache.org/jira/secure/ContactAdministrators!default.jspa
For more information on JIRA, see: http://www.atlassian.com/software/jira

        

Mime
View raw message