hadoop-mapreduce-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <Milind.Bhandar...@emc.com>
Subject Re: Trouble building 0.23 branch
Date Wed, 07 Dec 2011 18:00:02 GMT
Ralph,

Looks like you are using a Mac to build. The native components of the
build are not buildable on Mac. Disable native build by specifying
-P-native.

- Milind

---
Milind Bhandarkar
Greenplum Labs, EMC
(Disclaimer: Opinions expressed in this email are those of the author, and
do not necessarily represent the views of any organization, past or
present, the author might be affiliated with.)



On 12/7/11 9:24 AM, "Ralph Castain" <rhc@open-mpi.org> wrote:

>Hi folks
>
>I'm trying to build the 0.23 svn trunk today and am hitting the following
>error:
>
>INFO] --- make-maven-plugin:1.0-beta-1:make-install (compile) @
>hadoop-common ---
>[INFO] /bin/sh ./libtool  --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H
>-I.  -I/Library/Java/Home/include
>-I/Users/rhc/hadoop/branch-0.23/hadoop-common-project/hadoop-common/target
>/native/src 
>-I/Users/rhc/hadoop/branch-0.23/hadoop-common-project/hadoop-common/target
>/native/javah -I/usr/local/include -g -Wall -fPIC -O2 -m64 -gstabs+ -MT
>ZlibCompressor.lo -MD -MP -MF .deps/ZlibCompressor.Tpo -c -o
>ZlibCompressor.lo `test -f
>'src/org/apache/hadoop/io/compress/zlib/ZlibCompressor.c' || echo
>'./'`src/org/apache/hadoop/io/compress/zlib/ZlibCompressor.c
>[INFO] libtool: compile:  gcc -DHAVE_CONFIG_H -I.
>-I/Library/Java/Home/include
>-I/Users/rhc/hadoop/branch-0.23/hadoop-common-project/hadoop-common/target
>/native/src 
>-I/Users/rhc/hadoop/branch-0.23/hadoop-common-project/hadoop-common/target
>/native/javah -I/usr/local/include -g -Wall -fPIC -O2 -m64 -gstabs+ -MT
>ZlibCompressor.lo -MD -MP -MF .deps/ZlibCompressor.Tpo -c
>src/org/apache/hadoop/io/compress/zlib/ZlibCompressor.c  -fno-common
>-DPIC -o .libs/ZlibCompressor.o
>[INFO] src/org/apache/hadoop/io/compress/zlib/ZlibCompressor.c: In
>function 'Java_org_apache_hadoop_io_compress_zlib_ZlibCompressor_initIDs':
>[INFO] src/org/apache/hadoop/io/compress/zlib/ZlibCompressor.c:71: error:
>'libnotfound' undeclared (first use in this function)
>[INFO] src/org/apache/hadoop/io/compress/zlib/ZlibCompressor.c:71: error:
>(Each undeclared identifier is reported only once
>[INFO] src/org/apache/hadoop/io/compress/zlib/ZlibCompressor.c:71: error:
>for each function it appears in.)
>[INFO] make: *** [ZlibCompressor.lo] Error 1
>[INFO] 
>------------------------------------------------------------------------
>[INFO] Reactor Summary:
>[INFO] 
>[INFO] Apache Hadoop Annotations ......................... SUCCESS
>[9.191s]
>[INFO] Apache Hadoop Auth ................................ SUCCESS
>[6.852s]
>[INFO] Apache Hadoop Auth Examples ....................... SUCCESS
>[4.651s]
>[INFO] Apache Hadoop Common .............................. FAILURE
>[39.980s]
>[INFO] Apache Hadoop Common Project ...................... SKIPPED
>[INFO] 
>------------------------------------------------------------------------
>[INFO] BUILD FAILURE
>[INFO] 
>------------------------------------------------------------------------
>
>
>I've been following the instructions in the blogs and in INSTALL which
>worked fine until it hit this point. Any suggestions?
>
>Thanks
>Ralph
>
>


Mime
View raw message