hadoop-mapreduce-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Todd Lipcon (JIRA)" <j...@apache.org>
Subject [jira] Resolved: (MAPREDUCE-2194) Local mode seems to be broken in Cloudera's 737 release
Date Fri, 19 Nov 2010 16:49:15 GMT

     [ https://issues.apache.org/jira/browse/MAPREDUCE-2194?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Todd Lipcon resolved MAPREDUCE-2194.
------------------------------------

    Resolution: Invalid

Hi Alex. I transferred this ticket to the Cloudera DISTRO JIRA:https://issues.cloudera.org/browse/DISTRO-63

For CDH specific bugs it's best to either use that JIRA or our support portal, unless you
can reproduce upstream or in trunk.

> Local mode seems to be broken in Cloudera's 737 release
> -------------------------------------------------------
>
>                 Key: MAPREDUCE-2194
>                 URL: https://issues.apache.org/jira/browse/MAPREDUCE-2194
>             Project: Hadoop Map/Reduce
>          Issue Type: Bug
>    Affects Versions: 0.20.2
>            Reporter: Alex Rovner
>
> We have upgraded our dev environment from Cloudera's 0.20.2-228-cloudera to 0.20.2-737-cloudera
> Version 228 worked great for us. In version 737 we are getting the following exception:
> (LocalJobRunner.java:295) - job_local_0005
> java.lang.ClassCastException: org.apache.hadoop.mapreduce.lib.input.FileSplit cannot
be cast to org.apache.hadoop.mapred.InputSplit
> 	at org.apache.hadoop.mapred.MapTask.runOldMapper(MapTask.java:357)
> 	at org.apache.hadoop.mapred.MapTask.run(MapTask.java:317)
> 	at org.apache.hadoop.mapred.LocalJobRunner$Job.run(LocalJobRunner.java:212)
> We have tried to set job.getConfiguration().setBoolean("mapred.reducer.new-api", true)
but that did not resolve the issue.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message