hadoop-mapreduce-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Chris K Wensel <ch...@wensel.net>
Subject Re: Un-deprecate the old MapReduce API?
Date Thu, 22 Apr 2010 19:34:37 GMT

> * The next 0.20 release would have a non-deprecated old API.

+1

> * The forthcoming 0.21 release would have a "Stable" (non-deprecated)
> old API, and a "Evolving" new API.

+1

> * For some pre-1.0 release (perhaps 0.22), the old API could be
> deprecated again, and the new API marked as "Stable".
> * In the 1.0 release it would be possible to remove the old API.


thinking this is a different discussion.

but my preference is that 0.20 become 1.0 

buying time to evolve the evolving apis and build/dependency system over the next year(s)
into a 2.0

this could bite me as I do like some of the changes i had to effect in my cascading wip 2.0
api to support the 'new' apis.

but a 1.0 will send a very useful message to potential users

chris

--
Chris K Wensel
chris@concurrentinc.com
http://www.concurrentinc.com


Mime
View raw message