hadoop-hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stephen Watt <sw...@us.ibm.com>
Subject Build Crashing on Hive 0.5 Release
Date Thu, 02 Sep 2010 21:12:05 GMT
Hi Folks

I'm a Hadoop contributor and am presently working to get both Hadoop and 
Hive running on alternate JREs such as Apache Harmony and IBM Java. 

I noticed when building and running the functional tests ("clean test 
tar") for the Hive 0.5 release (i.e. not nightly build) , the build 
crashes right after running 
org.apache.hadoop.hive.ql.tool.TestLineageInfo. In addition, the 
TestCLIDriver Test Case fails as well. This is all using SUN JDK 1.60_14. 
I'm running on a SLES 10 system.

This is a little odd, given that this is a release and not a nightly 
build. Although, its not uncommon for me to see Hudson pass tests that 
fail when running locally. Can someone confirm the build works for them?

This is my build script:

#!/bin/sh

# Set Build Dependencies
set PATH=$PATH:/home/hive/Java-Versions/jdk1.6.0_14/bin/
export ANT_HOME=/home/hive/Test-Dependencies/apache-ant-1.7.1
export JAVA_HOME=/home/hive/Java-Versions/jdk1.6.0_14
export BUILD_DIR=/home/hive/hive-0.5.0-build
export HIVE_BUILD=$BUILD_DIR/build
export HIVE_INSTALL=$BUILD_DIR/hive-0.5.0-dev/
export HIVE_SRC=$HIVE_INSTALL/src
export PATH=$PATH:$ANT_HOME/bin

# Define Hadoop Version to Use
HADOOP_VER=0.20.2

# Run Build and Unit Test
cd $HIVE_SRC
ant -Dtarget.dir=$HIVE_BUILD -Dhadoop.version=$HADOOP_VER clean test tar > 
$BUILD_DIR/hiveSUN32Build.out


Regards
Steve Watt 
Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message