hadoop-hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Stephen Watt (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HIVE-1646) Hive 0.5 Build Crashing
Date Thu, 30 Sep 2010 01:23:32 GMT

    [ https://issues.apache.org/jira/browse/HIVE-1646?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12916336#action_12916336
] 

Stephen Watt commented on HIVE-1646:
------------------------------------

I finally have this working. Apparently, the src tree from the Release TAR is what does not
build. i.e. the tarball you get from "Hive Downloads". If you go ahead and do an svn checkout
of "http://svn.apache.org/repos/asf/hadoop/hive/tags/release-0.5.0/" it will build. For the
record, I was using ANT 1.8.1 and SUN JDK 1.6.14 

I'm going to leave this open as there is still an issue as the Tarball is clearly different
to the tagged release.

> Hive 0.5 Build Crashing
> -----------------------
>
>                 Key: HIVE-1646
>                 URL: https://issues.apache.org/jira/browse/HIVE-1646
>             Project: Hadoop Hive
>          Issue Type: Bug
>          Components: Testing Infrastructure
>    Affects Versions: 0.5.0
>         Environment: SLES 10 SP2, SLES 11, RHEL 5.4, ANT 1.8.1 and ANT 1.7.1, SUN JDK
1.6.14
>            Reporter: Stephen Watt
>             Fix For: 0.5.1
>
>
> I've tried this on a variety of configurations. Operating Systems SLES 10 SP2, SLES 11,
RHEL 5.4 on a variety of machines using both ANT 1.8.1 and ANT 1.7.1 and SUN JDK 1.6.14. I've
tried building this by going to the Hive Release page and download hive-0.5.0-src and using
that. I've tried building by obtaining the branch tag release using svn checkout http://svn.apache.org/repos/asf/hadoop/hive/tags/release-0.5.0/
hive-0.5.0-dev. Always the same thing:
> When I run the Hive 0.5 build it runs for just under 2 hours and then crashes with the
following message (tail end of ant.log):
> - - -
>     [junit] diff /home/hive/hive-0.5.0-build/hive-0.5.0-dev/build/ql/test/logs/negative/wrong_distinct2.q.out
/home/hive/hive-0.5.0-build/hive-0.5.0-dev/ql/src/test/results/compiler/errors/wrong_distinct2.q.out
>     [junit] Done query: wrong_distinct2.q
>     [junit] Tests run: 31, Failures: 0, Errors: 0, Time elapsed: 90.974 sec
>     [junit] Running org.apache.hadoop.hive.ql.tool.TestLineageInfo
>     [junit] Tests run: 5, Failures: 0, Errors: 0, Time elapsed: 0.525 sec
> BUILD FAILED
> /home/hive/hive-0.5.0-build/hive-0.5.0-dev/build.xml:151: The following error occurred
while executing this line:
> /home/hive/hive-0.5.0-build/hive-0.5.0-dev/build.xml:91: The following error occurred
while executing this line:
> /home/hive/hive-0.5.0-build/hive-0.5.0-dev/build-common.xml:327: Tests failed!
> Total time: 94 minutes 43 seconds
> - - -
> My build script is very simplistic :
> #!/bin/sh
> # Set Build Dependencies
> set PATH=$PATH:/home/hive/Java-Versions/jdk1.6.0_14/bin/
> export JAVA_HOME=/home/hive/Java-Versions/jdk1.6.0_14
> export BUILD_DIR=/home/hive/hive-0.5.0-build
> export ANT_HOME=$BUILD_DIR/apache-ant-1.8.1
> export HIVE_INSTALL=$BUILD_DIR/hive-0.5.0-dev/
> export PATH=$PATH:$ANT_HOME/bin
> # Run Build and Unit Test
> cd $HIVE_INSTALL
> ant clean test tar -logfile ant.log

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message