hadoop-hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Edward Capriolo <edlinuxg...@gmail.com>
Subject Hive Web Interface Broken YET AGAIN!
Date Thu, 29 Jul 2010 14:38:25 GMT
All,

While the web interface is not as widely used as the cli, people do
use it. Its init process has been broken 3 times I can remember (once
by the shims), once by adding version numbers to the jars, and now it
is affected by the libjars.

[root@etl02 ~]# hive --service hwi
Exception in thread "main" java.io.IOException: Error opening job jar: -libjars
	at org.apache.hadoop.util.RunJar.main(RunJar.java:90)
Caused by: java.util.zip.ZipException: error in opening zip file
	at java.util.zip.ZipFile.open(Native Method)
	at java.util.zip.ZipFile.<init>(ZipFile.java:114)
	at java.util.jar.JarFile.<init>(JarFile.java:133)
	at java.util.jar.JarFile.<init>(JarFile.java:70)
	at org.apache.hadoop.util.RunJar.main(RunJar.java:88)

I notice someone patched the cli do deal with this. There is no test
coverage for the shell scripts.

But it seems like only some of the scripts were repaired:

bin/ext/cli.sh
bin/ext/lineage.sh
bin/ext/metastore.sh

I wonder why only half the scripts are repaired? In general if
something changes in hive or hadoop that causes the cli to break we
should fix it across the board. I feel like every time a release is
coming up I test drive the web interface to find a simple script
problem stops it from running.

Edward

Mime
View raw message