hadoop-hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Carl Steinbach (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HIVE-1264) Make Hive work with Hadoop security
Date Wed, 21 Jul 2010 20:35:51 GMT

    [ https://issues.apache.org/jira/browse/HIVE-1264?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12890877#action_12890877
] 

Carl Steinbach commented on HIVE-1264:
--------------------------------------

@Venkatesh: I looked at your patch. Your changes break the build when compiled against any
version of Hadoop that does not include the new security APIs. Hive is currently designed
to maintain backward compatibility with Hadoop 0.17, 0.18, 0.19 and 0.20 using a shim layer.
In order to get this patch committed you will need to modify the shim layer and ensure that
you have not broken compatibility with any of these older versions of Hadoop.


> Make Hive work with Hadoop security
> -----------------------------------
>
>                 Key: HIVE-1264
>                 URL: https://issues.apache.org/jira/browse/HIVE-1264
>             Project: Hadoop Hive
>          Issue Type: Improvement
>            Reporter: Jeff Hammerbacher
>         Attachments: HiveHadoop20S_patch.patch
>
>


-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message