hadoop-hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Carl Steinbach (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HIVE-1427) Provide metastore schema migration scripts (0.5 -> 0.6)
Date Fri, 23 Jul 2010 01:50:52 GMT

    [ https://issues.apache.org/jira/browse/HIVE-1427?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12891444#action_12891444
] 

Carl Steinbach commented on HIVE-1427:
--------------------------------------

Here's my plan:

 * Go with the minimal approach of only providing a MySQL upgrade script that upgrades 0.5.0->0.6.0
and 0.6.0->trunk
 * Include changes made here: http://wiki.apache.org/hadoop/Hive/ViewDev#Metastore_Upgrades
 * The scripts will live in metastore/scripts
 * Document the upgrade process in the release notes.


> Provide metastore schema migration scripts (0.5 -> 0.6)
> -------------------------------------------------------
>
>                 Key: HIVE-1427
>                 URL: https://issues.apache.org/jira/browse/HIVE-1427
>             Project: Hadoop Hive
>          Issue Type: Task
>          Components: Metastore
>            Reporter: Carl Steinbach
>            Assignee: Carl Steinbach
>             Fix For: 0.6.0, 0.7.0
>
>
> At a minimum this ticket covers packaging up example MySQL migration scripts (cumulative
across all schema changes from 0.5 to 0.6) and explaining what to do with them in the release
notes.
> This is also probably a good point at which to decide and clearly state which Metastore
DBs we officially support in production, e.g. do we need to provide migration scripts for
Derby?

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message