hadoop-hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Basab Maulik (JIRA)" <j...@apache.org>
Subject [jira] Updated: (HIVE-1229) replace dependencies on HBase deprecated API
Date Tue, 08 Jun 2010 21:08:12 GMT

     [ https://issues.apache.org/jira/browse/HIVE-1229?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Basab Maulik updated HIVE-1229:
-------------------------------

    Attachment: HIVE-1129.1.patch

I have attached a preliminary patch for this issue for feedback/comments. The patch includes
changes from HIVE-1383.3.patch.

With the patch applied the following tests pass:

ant test -Dtestcase=TestHBaseSerDe
ant test -Dtestcase=TestLazyHBaseObject
ant test -Dtestcase=TestHBaseCliDriver -Dqfile=hbase_queries.q

.. the following fails:

ant clean test tar -logfile ant.log

'ant testreport' shows six failures in ql/parse.

I think these failures are from my environment rather than the patch?

I may also need to fix some checkstyle violations.

> replace dependencies on HBase deprecated API
> --------------------------------------------
>
>                 Key: HIVE-1229
>                 URL: https://issues.apache.org/jira/browse/HIVE-1229
>             Project: Hadoop Hive
>          Issue Type: Improvement
>          Components: HBase Handler
>    Affects Versions: 0.6.0
>            Reporter: John Sichi
>            Assignee: Basab Maulik
>             Fix For: 0.6.0
>
>         Attachments: HIVE-1129.1.patch
>
>
> Some of these dependencies are on the old Hadoop mapred packages; others are HBase-specific.
 The former have to wait until the rest of Hive moves over to the new Hadoop mapreduce package,
but the HBase-specific ones don't have to wait.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message