hadoop-hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jerome Boulon (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HIVE-259) Add PERCENTILE aggregate function
Date Thu, 25 Feb 2010 03:20:28 GMT

    [ https://issues.apache.org/jira/browse/HIVE-259?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12838173#action_12838173

Jerome Boulon commented on HIVE-259:

- From my point of view, changing variable access to private in the state object will not
make the code more readable ...
- I'll change all variables to be lowerCase to match java style, current variable's name are
based on Oracle definition.

@Zheng - I'm not using an ArrayList<Integer> but a String to avoid unnecessary object
creation (for every single row) ... would even be better if the constructor could have been
used but I haven't found how to do that. If we care about 1 extra empty arrayList per mapper/spill
in memory then we should care about creating (1 ArrayList + 1 Integer Object per percentile)
per row.

@Zheng - Regarding the test case that what I add in mind when I asked you, howto create my
own table and that exactly the reason why I post Jb2.* files

> Add PERCENTILE aggregate function
> ---------------------------------
>                 Key: HIVE-259
>                 URL: https://issues.apache.org/jira/browse/HIVE-259
>             Project: Hadoop Hive
>          Issue Type: New Feature
>          Components: Query Processor
>            Reporter: Venky Iyer
>            Assignee: Jerome Boulon
>         Attachments: HIVE-259-2.patch, HIVE-259.1.patch, HIVE-259.patch, jb2.txt, Percentile.xlsx
> Compute atleast 25, 50, 75th percentiles

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message