hadoop-hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "He Yongqiang (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HIVE-1138) Hive using lzo comporession returns unexpected results.
Date Mon, 08 Feb 2010 20:55:28 GMT

    [ https://issues.apache.org/jira/browse/HIVE-1138?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12831112#action_12831112
] 

He Yongqiang commented on HIVE-1138:
------------------------------------

1) Can you check if LzoCodec is loaded/installed correctly? (Is LzoCodec removed from the
Hadoop version you used, if yes, how you installed and used it in Hive?)
2) If yes for 1, can you upload a small piece of data, no need for real data, i think a test
table with some data will ok. Just make sure i can reproduce the problem.

> Hive using lzo comporession returns unexpected results.
> -------------------------------------------------------
>
>                 Key: HIVE-1138
>                 URL: https://issues.apache.org/jira/browse/HIVE-1138
>             Project: Hadoop Hive
>          Issue Type: Bug
>          Components: Query Processor
>    Affects Versions: 0.6.0
>         Environment: hadoop 0.20.1, hive trunk 2010-02-03
>            Reporter: Bennie Schut
>            Priority: Blocker
>
> I have a tab separated files I have loaded it with "load data inpath" then I do a
> SET hive.exec.compress.output=true;
> SET mapred.output.compression.codec=com.hadoop.compression.lzo.LzoCodec;
> SET mapred.map.output.compression.codec=com.hadoop.compression.lzo.LzoCodec;
> select distinct login_cldr_id as cldr_id from chatsessions_load;
> Ended Job = job_201001151039_1641
> OK
> NULL
> NULL
> NULL
> Time taken: 49.06 seconds
> however if I start it without the set commands I get this:
> Ended Job = job_201001151039_1642
> OK
> 2283
> Time taken: 45.308 seconds
> Which is the correct result.
> When I do a "insert overwrite" on a rcfile table it will actually compress the data correctly.
> When I disable compression and query this new table the result is correct.
> When I enable compression it's wrong again.
> I see no errors in the logs.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message