hadoop-hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Zheng Shao (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HIVE-1068) CREATE VIEW followup: add a "table type" enum attribute in metastore's MTable, and also null out irrelevant attributes for MTable instances which describe views
Date Fri, 29 Jan 2010 06:01:37 GMT

    [ https://issues.apache.org/jira/browse/HIVE-1068?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12806243#action_12806243
] 

Zheng Shao commented on HIVE-1068:
----------------------------------

The meaning of isNativeSerDe(String) changed. Can we rename it to "shouldGetColsFromSerDe"
(and invert the condition)?


> CREATE VIEW followup:  add a "table type" enum attribute in metastore's MTable, and also
null out irrelevant attributes for MTable instances which describe views
> -----------------------------------------------------------------------------------------------------------------------------------------------------------------
>
>                 Key: HIVE-1068
>                 URL: https://issues.apache.org/jira/browse/HIVE-1068
>             Project: Hadoop Hive
>          Issue Type: Improvement
>          Components: Metastore
>    Affects Versions: 0.6.0
>            Reporter: John Sichi
>            Assignee: John Sichi
>             Fix For: 0.6.0
>
>         Attachments: HIVE-1068.1.patch
>
>
> Zheng's description:
> 5. TODO: Metadata change: We store "view" definitions in the same metadata table that
we store "table" definitions.
> Shall we add a field "table type" so we know whether it's a table, external table, view,
or materialized view in the future.
> We should clean up the additional useless fields in "view" - the test output shows that
we are storing some garbage information for views.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message