hadoop-hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chad Metcalf (JIRA)" <j...@apache.org>
Subject [jira] Commented: (HIVE-978) Hive jars should follow Hadoop naming and include version
Date Sat, 12 Dec 2009 05:02:18 GMT

    [ https://issues.apache.org/jira/browse/HIVE-978?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=12789683#action_12789683

Chad Metcalf commented on HIVE-978:

> I think we learned that ${HIVE_HOME} is not expanded by HiveConf.

I changed HiveConf.java to point to ${HWI_WAR_FILE}

--- a/common/src/java/org/apache/hadoop/hive/conf/HiveConf.java
+++ b/common/src/java/org/apache/hadoop/hive/conf/HiveConf.java
@@ -134,7 +134,7 @@ public class HiveConf extends Configuration {
     // HWI
-    HIVEHWIWARFILE("hive.hwi.war.file",System.getenv("HIVE_HOME")+"/lib/hive_hwi.war"),
+    HIVEHWIWARFILE("hive.hwi.war.file",System.getenv("HWI_WAR_FILE")),
     // mapper/reducer memory in local mode
     HIVEHADOOPMAXMEM("hive.mapred.local.mem", 0),

I realize this doesn't work in the defaults. Not sure how to codify the defaults to show the
default without resorting to 

1) a life time of updating the version numbers
2) writing a script to do the updating which will probably be forgotten and never run

It makes sense for the HiveConf to go straight to the HWI_WAR_FILE env var. We take the time
to set it and its easy to remember to fix. But I don't know the right way to then reflect
that in the defaults file. Ideas, anyone?

> Hive jars should follow Hadoop naming and include version
> ---------------------------------------------------------
>                 Key: HIVE-978
>                 URL: https://issues.apache.org/jira/browse/HIVE-978
>             Project: Hadoop Hive
>          Issue Type: Improvement
>          Components: Build Infrastructure
>    Affects Versions: 0.5.0
>            Reporter: Chad Metcalf
>            Priority: Minor
>             Fix For: 0.5.0
>         Attachments: HIVE-978v1.patch, HIVE-978v2.patch
> This is a simple patch on the ant build files to change jar naming from
> hive_foo.jar to hive-foo-VERSION.jar
> This matches the convention followed by hadoop jars. This naming scheme is important
for packaging, repositories, etc.
> Testing done:
> ant test
> ant tar
> Things look right.

This message is automatically generated by JIRA.
You can reply to this email to add a comment to the issue online.

View raw message