hadoop-hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Carl Steinbach (JIRA)" <j...@apache.org>
Subject [jira] Created: (HIVE-986) Ant "eclipse-files" target is broken for Hadoop 0.20
Date Mon, 14 Dec 2009 18:35:18 GMT
Ant "eclipse-files" target is broken for Hadoop 0.20
----------------------------------------------------

                 Key: HIVE-986
                 URL: https://issues.apache.org/jira/browse/HIVE-986
             Project: Hadoop Hive
          Issue Type: Bug
          Components: Build Infrastructure
            Reporter: Carl Steinbach



Hadoop 0.20 depends on servlet-api-2.5-6.1.14.jar and jetty-6.1.14.jar/jetty-util-6.1.11.jar
instead of servlet-api.jar and jetty-5.1.4.jar.

The eclipse-files ant target needs to be updated to take this account (which involves editing
eclipse-templates/.classpath)
and adding some conditional logic to build.xml

Here's what you see currently after importing into eclipse:

Project 'apache-hive' is missing required library: 'build/hadoopcore/hadoop-0.20.0/lib/jetty-5.1.4.jar'
Project 'apache-hive' is missing required library: 'build/hadoopcore/hadoop-0.20.0/lib/servlet-api.jar'



-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message