hadoop-hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Venkat Ramachandran (JIRA)" <j...@apache.org>
Subject [jira] Created: (HIVE-752) Encountered ClassNotFound exception when trying HWI server
Date Wed, 12 Aug 2009 23:38:14 GMT
Encountered ClassNotFound exception when trying HWI server
----------------------------------------------------------

                 Key: HIVE-752
                 URL: https://issues.apache.org/jira/browse/HIVE-752
             Project: Hadoop Hive
          Issue Type: Bug
          Components: Clients
         Environment: Hadoop 0.18.3
            Reporter: Venkat Ramachandran


Encountered ClassNotFound exception (for class: org.apache.jetty.hive.shims.Jetty18Shims)
when trying to start HWI server on Hadoop 18.

It appears that the class ShimLoader (org.apache.hadoop.hive.shims.ShimLoader) is referring
to incorrect classes as below:

static {
    JETTY_SHIM_CLASSES.put("0.17", "org.apache.jetty.hive.shims.Jetty17Shims");
    JETTY_SHIM_CLASSES.put("0.18", "org.apache.jetty.hive.shims.Jetty18Shims");
    JETTY_SHIM_CLASSES.put("0.19", "org.apache.jetty.hive.shims.Jetty19Shims");
    JETTY_SHIM_CLASSES.put("0.20", "org.apache.jetty.hive.shims.Jetty20Shims");
  }

however, I think it should be as below:

 static 
  {
	  JETTY_SHIM_CLASSES.put("0.17", "org.apache.hadoop.hive.shims.Jetty17Shims");
	  JETTY_SHIM_CLASSES.put("0.18", "org.apache.hadoop.hive.shims.Jetty18Shims");
	  JETTY_SHIM_CLASSES.put("0.19", "org.apache.hadoop.hive.shims.Jetty19Shims");
	  JETTY_SHIM_CLASSES.put("0.20", "org.apache.hadoop.hive.shims.Jetty20Shims");
  } 

Wondering if anybody else encountered this.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message