hadoop-hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Rakhi Khatwani <rkhatw...@gmail.com>
Subject Problem running the getting started tutorial
Date Mon, 27 Jul 2009 09:46:18 GMT
Hi,
        i downloaded the source from svn
set HADOOP_HOME and HIVE_HOME and performed the ant command as follows:
ant -Dhadoop.version="0.19.0" package
i get the following errors:
Buildfile: build.xml

jar:

init:
  [mkdir] Created dir: /home/ithurs/hive/build
  [mkdir] Created dir: /home/ithurs/hive/build/common
  [mkdir] Created dir: /home/ithurs/hive/build/common/classes
  [mkdir] Created dir: /home/ithurs/hive/build/jexl/classes
  [mkdir] Created dir: /home/ithurs/hive/build/hadoopcore
  [mkdir] Created dir: /home/ithurs/hive/build/common/test
  [mkdir] Created dir: /home/ithurs/hive/build/common/test/src
  [mkdir] Created dir: /home/ithurs/hive/build/common/test/classes

install-hadoopcore:

install-hadoopcore-default:

download-ivy:
  [get] Getting:
http://www.apache.org/dist/ant/ivy/2.0.0-rc2/apache-ivy-2.0.0-rc2-bin.zip
  [get] To: /root/.ant/apache-ivy-2.0.0-rc2-bin.zip
  [get] Not modified - so not downloaded
  [unzip] Expanding: /root/.ant/apache-ivy-2.0.0-rc2-bin.zip into /root/.ant

BUILD FAILED
/home/ithurs/hive/build.xml:114: The following error occurred while
executing this line:
/home/ithurs/hive/build.xml:73: The following error occurred while executing
this line:
/home/ithurs/hive/build-common.xml:100: The following error occurred while
executing this line:
/home/ithurs/hive/build-common.xml:91: The following error occurred while
executing this line:
/home/ithurs/hive/ivy/get_ivy.xml:36: Error while expanding
/root/.ant/apache-ivy-2.0.0-rc2-bin.zip
java.io.IOException: Negative seek offset

______________________________________________
whn i go to the bin directory and run ./hive,  i get the following
exception:
./hive

java.lang.NoClassDefFoundError: org/apache/hadoop/hive/conf/HiveConf
  at java.lang.Class.forName0(Native Method)
  at java.lang.Class.forName(Class.java:247)
  at org.apache.hadoop.util.RunJar.main(RunJar.java:158)
  at org.apache.hadoop.mapred.JobShell.run(JobShell.java:54)
  at org.apache.hadoop.util.ToolRunner.run(ToolRunner.java:65)
  at org.apache.hadoop.util.ToolRunner.run(ToolRunner.java:79)
  at org.apache.hadoop.mapred.JobShell.main(JobShell.java:68)
Caused by: java.lang.ClassNotFoundException:
org.apache.hadoop.hive.conf.HiveConf
  at java.net.URLClassLoader$1.run(URLClassLoader.java:200)
  at java.security.AccessController.doPrivileged(Native Method)
  at java.net.URLClassLoader.findClass(URLClassLoader.java:188)
  at java.lang.ClassLoader.loadClass(ClassLoader.java:307)
  at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
  at java.lang.ClassLoader.loadClassInternal(ClassLoader.java:320)
  ... 7 more
am i facing problems coz m using hadoop-0.19.0 version??
Regards,
Raakhi

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message