hadoop-hive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Raghotham Murthy (JIRA)" <j...@apache.org>
Subject [jira] Updated: (HIVE-272) Eliminate @Override directives for classes in Eclipse 3.4.1
Date Thu, 05 Feb 2009 00:07:59 GMT

     [ https://issues.apache.org/jira/browse/HIVE-272?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Raghotham Murthy updated HIVE-272:
----------------------------------

        Fix Version/s: 0.3.0
    Affects Version/s: 0.2.0
         Release Note: Removed @Override to be compatible with eclipse versions greater than
3.4.1.  (was: Eclipse 3.4.1 requirements for @Override directives.)
               Status: Patch Available  (was: Open)

> Eliminate @Override directives for classes in Eclipse 3.4.1
> -----------------------------------------------------------
>
>                 Key: HIVE-272
>                 URL: https://issues.apache.org/jira/browse/HIVE-272
>             Project: Hadoop Hive
>          Issue Type: Improvement
>          Components: Build Infrastructure
>    Affects Versions: 0.2.0
>         Environment: Eclipse 3.4.1
>            Reporter: Shyam Sundar Sarkar
>            Assignee: Raghotham Murthy
>             Fix For: 0.3.0
>
>         Attachments: hive-272.1.patch
>
>
> Eclipse Versions prior to 3.4.1 actually add @Override to classes which
> implement interfaces. Version 3.4.1 correctly complains that @Override
> should not be present for methods from interfaces.

-- 
This message is automatically generated by JIRA.
-
You can reply to this email to add a comment to the issue online.


Mime
View raw message